カテゴリー別アーカイブ: MovableType

Movable Type 4.27 アップデート

アップグレードを強く推奨しますということで、アップグレードしてみた。

 

今回は(5に対応していないプラグインがあるので)5にはせず、4.23 → 4.27 へアップデート。

 

初体験なので、アップグレードの仕方をネットで調べます

————————————————–

1)ブログのバックアップを取る

2)MTOS-4_27-ja.zipをダウンロードして解凍

3)ファイルを上書きアップロード

4)ログインすると自動的にアップデート

————————————————–

らしい、、、で早速実行。

 

1)ブログのバックアップを取る

 MovableTypeダッシュボード – システムメニュー – ツール – バックアップ で簡単にできた、のだけど、実行ログメッセージの最後に、

 バックアップはディレクトリ /tmpに正常に保存されたけど、早くそのファイルはダウンロードして /tmpへバックアップしたファイルは消したほうが良いよ!みたいなメッセージが出てきた。

 んで、 /tmp を探すけどサーバー上に見当たらない、

 結局これ→ バックアップの保存先「/tmp」とはどこですかだった 時既に遅し、スルーする。

 

2)MTOS-4_27-ja.zipをダウンロードして解凍

 もちろん簡単なことですが、後から MT-4_27-ja.zip をダウンロードしていた事に気づく。おそらく問題はないでしょう。うんないんだ、、、

 

3)ファイルを上書きアップロード

 途中でよくFTPが失敗したので、5回ほど繰り返す(クッソー)。なにせ、2800個くらいファイルがありますので。それと、途中で1個のファイル「../codepress/engines/khtml.js」 が、「425 Unable to build data connection: Cannot assign requested address 」でアップロードできなかったけど、何回も繰り返していたので やり直す気力無く、これもスルー

 

4)ログインすると自動的にアップデート

 ログインすると、Got an error: syntax error ってなる。「えっ、水の泡か!」って思ったけど、プラグインを導入した時に同じメッセージが出て苦労したのを思い出す。(超ド素人です)

 Perlプログラム(拡張子が .cgi)のPerlのパスをサーバーにあわせてOK!

 自動的にアップデートが始る、と、いきなり、

新しいバージョンの Movable Type をインストールしました。データベースのアップグレードを実行してください。

アップグレードに関する情報はここで見ることができます。

加えて、以下のコンポーネントのアップグレード、またはインストールが必要です。

” Community Pack バージョン 1.631

” Professional Pack バージョン 1.301

” Action Streams バージョン 2.1

” Motion バージョン 1.0

って言われたけど、もちろんこれもスルー

 

以上スルーの多いアップグレードでした。 ヾ(@°▽°@)ノあはは

参考になりませんよね..

 

ブログランキングに登録しています。
すみませんこちらをクリックしてご協力お願いします。